Error Divi WoocommerceProductVariablePlaceholder.php on line 8

error wordpress divi line 8

Il semble qu’un bug empêche l’accès à l’administration de votre site WordPress dans le cas ou vous utiliseriez la version de Divi 4.5.6

Le message d’erreur en question est :

Theme_Builder_Woocommerce_Product_Variable_Placeholder::get_available_variations() should be compatible with WC_Product_Variable::get_available_variations($return = ‘array’) in /home/.sites/949/site75577549/web/wp-content/themes/Divi/includes/builder/frontend-builder/theme-builder/WoocommerceProductVariablePlaceholder.php on line 8

 

Pour le corriger, vous devez vous connecter à votre serveur FTP et vous rendre dans le répertoire :

wp-content/themes/Divi/includes/builder/frontend-builder/theme-builder/

 

Puis ouvrir le fichier : WoocommerceProductVariablePlaceholder.php

Vous pouvez ouvrir le fichier avec un simple bloc note, une fois dedans, rendez vous à la ligne 199.

Vous allez devoir remplacer:

 

function get_available_variations() {
		return array(
			$this->get_available_variation(),
		);
	}

 

par ceci :

 

function get_available_variations($return = 'array') {
		return array(
			$this->get_available_variation(),
		);
	}

 

Et voila, problème réglé en attendant la prochaine mise à jour qui ne devrait pas tarder à arriver ! 😉